Incidents

Aven.com Session Acquisition Issue

resolvedMAJORaffectedAven Landing Pagelasted 7min 3s

The incident has been resolved

resolved
Jun 9 17:13:41 (UTC)

The service is experiance an issue, we will update shortly.

investigating
Jun 9 17:06:38 (UTC)
Powered by Checkly