Aven
Get updates
Status
Activity
Incidents
Aven.com Session Acquisition Issue
resolved
MAJOR
affected
Aven Landing Page
lasted 9min 49s
The incident has been resolved
resolved
Jun 8 19:16:32 (UTC)
resolved
The service is experiance an issue, we will update shortly.
investigating
Jun 8 19:06:42 (UTC)
investigating
Powered by
Checkly